KW V2's installed - Mercedes-Benz Forum : AMG Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 03-11-2009, 05:38 AM Thread Starter
Senior Member
Broken in!
 
Join Date: Jun 2008
Location: Bay Area, CA
Posts: 1,173
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
KW V2's installed

Excuse the dirty car!





Right after install - rears haven't settled yet.



After test drive - rears settled:







What came off the car - Brabus suspension:







Installed by Works Motorsports. HRE's ordered today from Sonic. Sonic's going to install my BBK when my HRE's get in


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
tbone is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-01-2010, 06:11 AM
Junior Member
 
Join Date: Apr 2010
Location: New York
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
What you feel after installing KW V2 in your car? have you noticed any change.
aja72 is offline  
post #3 of 3 (permalink) Old 04-01-2010, 01:02 PM
Senior Member
Shoot Me Already!
 
Join Date: Mar 2007
Location: Socal
Posts: 14,346
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Benzoboi
Gangsta!

4 door sedan with a couple "go fast" mods and some wheels...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Another great sig brought to you by Shake!
Benzoboi is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome